Add games-action/supertuxkart-0.8.1. with patches
[shuber-gentoo-overlay.git] / games-action / supertuxkart / files / supertuxkart-0.8.1-irrlicht.patch
diff --git a/games-action/supertuxkart/files/supertuxkart-0.8.1-irrlicht.patch b/games-action/supertuxkart/files/supertuxkart-0.8.1-irrlicht.patch
new file mode 100644 (file)
index 0000000..43130d1
--- /dev/null
@@ -0,0 +1,69 @@
+unbundle Irrlicht dependencies
+and respect CFLAGS
+
+--- lib/irrlicht/include/IrrCompileConfig.h
++++ lib/irrlicht/include/IrrCompileConfig.h
+@@ -245,7 +245,7 @@
+ //! Define _IRR_USE_NON_SYSTEM_JPEG_LIB_ to let irrlicht use the jpeglib which comes with irrlicht.\r
+ /** If this is commented out, Irrlicht will try to compile using the jpeg lib installed in the system.\r
+       This is only used when _IRR_COMPILE_WITH_LIBJPEG_ is defined. */\r
+-#define _IRR_USE_NON_SYSTEM_JPEG_LIB_\r
++//#define _IRR_USE_NON_SYSTEM_JPEG_LIB_\r
+ #ifdef NO_IRR_USE_NON_SYSTEM_JPEG_LIB_\r
+ #undef _IRR_USE_NON_SYSTEM_JPEG_LIB_\r
+ #endif\r
+@@ -261,7 +261,7 @@
+ //! Define _IRR_USE_NON_SYSTEM_LIBPNG_ to let irrlicht use the libpng which comes with irrlicht.\r
+ /** If this is commented out, Irrlicht will try to compile using the libpng installed in the system.\r
+       This is only used when _IRR_COMPILE_WITH_LIBPNG_ is defined. */\r
+-#define _IRR_USE_NON_SYSTEM_LIB_PNG_\r
++//#define _IRR_USE_NON_SYSTEM_LIB_PNG_\r
+ #ifdef NO_IRR_USE_NON_SYSTEM_LIB_PNG_\r
+ #undef _IRR_USE_NON_SYSTEM_LIB_PNG_\r
+ #endif\r
+@@ -598,7 +598,7 @@
+ /** If this is commented out, Irrlicht will try to compile using the zlib\r
+ installed on the system. This is only used when _IRR_COMPILE_WITH_ZLIB_ is\r
+ defined. */\r
+-#define _IRR_USE_NON_SYSTEM_ZLIB_\r
++//#define _IRR_USE_NON_SYSTEM_ZLIB_\r
+ #ifdef NO_IRR_USE_NON_SYSTEM_ZLIB_\r
+ #undef _IRR_USE_NON_SYSTEM_ZLIB_\r
+ #endif\r
+--- lib/irrlicht/source/Irrlicht/Makefile
++++ lib/irrlicht/source/Irrlicht/Makefile
+@@ -46,11 +46,7 @@
+ IRRIOOBJ = CFileList.o CFileSystem.o CLimitReadFile.o CMemoryFile.o CReadFile.o CWriteFile.o CXMLReader.o CXMLWriter.o CWADReader.o CZipReader.o CPakReader.o CNPKReader.o CTarReader.o CMountPointReader.o irrXML.o CAttributes.o lzma/LzmaDec.o\r
+ IRROTHEROBJ = CIrrDeviceSDL.o CIrrDeviceLinux.o CIrrDeviceConsole.o CIrrDeviceStub.o CIrrDeviceWin32.o CIrrDeviceFB.o CLogger.o COSOperator.o Irrlicht.o os.o\r
+ IRRGUIOBJ = CGUIButton.o CGUICheckBox.o CGUIComboBox.o CGUIContextMenu.o CGUIEditBox.o CGUIEnvironment.o CGUIFileOpenDialog.o CGUIFont.o CGUIImage.o CGUIInOutFader.o CGUIListBox.o CGUIMenu.o CGUIMeshViewer.o CGUIMessageBox.o CGUIModalScreen.o CGUIScrollBar.o CGUISpinBox.o CGUISkin.o CGUIStaticText.o CGUITabControl.o CGUITable.o CGUIToolBar.o CGUIWindow.o CGUIColorSelectDialog.o CDefaultGUIElementFactory.o CGUISpriteBank.o CGUIImageList.o CGUITreeView.o\r
+-ZLIBOBJ = zlib/adler32.o zlib/compress.o zlib/crc32.o zlib/deflate.o zlib/inffast.o zlib/inflate.o zlib/inftrees.o zlib/trees.o zlib/uncompr.o zlib/zutil.o\r
+-JPEGLIBOBJ = jpeglib/jcapimin.o jpeglib/jcapistd.o jpeglib/jccoefct.o jpeglib/jccolor.o jpeglib/jcdctmgr.o jpeglib/jchuff.o jpeglib/jcinit.o jpeglib/jcmainct.o jpeglib/jcmarker.o jpeglib/jcmaster.o jpeglib/jcomapi.o jpeglib/jcparam.o jpeglib/jcprepct.o jpeglib/jcsample.o jpeglib/jctrans.o jpeglib/jdapimin.o jpeglib/jdapistd.o jpeglib/jdatadst.o jpeglib/jdatasrc.o jpeglib/jdcoefct.o jpeglib/jdcolor.o jpeglib/jddctmgr.o jpeglib/jdhuff.o jpeglib/jdinput.o jpeglib/jdmainct.o jpeglib/jdmarker.o jpeglib/jdmaster.o jpeglib/jdmerge.o jpeglib/jdpostct.o jpeglib/jdsample.o jpeglib/jdtrans.o jpeglib/jerror.o jpeglib/jfdctflt.o jpeglib/jfdctfst.o jpeglib/jfdctint.o jpeglib/jidctflt.o jpeglib/jidctfst.o jpeglib/jidctint.o jpeglib/jmemmgr.o jpeglib/jmemnobs.o jpeglib/jquant1.o jpeglib/jquant2.o jpeglib/jutils.o jpeglib/jcarith.o jpeglib/jdarith.o jpeglib/jaricom.o\r
+-LIBPNGOBJ = libpng/png.o libpng/pngerror.o libpng/pngget.o libpng/pngmem.o libpng/pngpread.o libpng/pngread.o libpng/pngrio.o libpng/pngrtran.o libpng/pngrutil.o libpng/pngset.o libpng/pngtrans.o libpng/pngwio.o libpng/pngwrite.o libpng/pngwtran.o libpng/pngwutil.o\r
+ LIBAESGM = aesGladman/aescrypt.o aesGladman/aeskey.o aesGladman/aestab.o aesGladman/fileenc.o aesGladman/hmac.o aesGladman/prng.o aesGladman/pwd2key.o aesGladman/sha1.o aesGladman/sha2.o\r
+-BZIP2OBJ = bzip2/blocksort.o bzip2/huffman.o bzip2/crctable.o bzip2/randtable.o bzip2/bzcompress.o bzip2/decompress.o bzip2/bzlib.o\r
\r
+ # Next variable is for additional scene nodes etc. of customized Irrlicht versions\r
+ EXTRAOBJ =\r
+@@ -61,18 +57,16 @@
\r
+ ###############\r
+ #Compiler flags\r
+-CXXINCS = -I../../include -Izlib -Ijpeglib -Ilibpng\r
++CXXINCS = -I../../include\r
+ CPPFLAGS += $(CXXINCS) -DIRRLICHT_EXPORTS=1\r
+-CXXFLAGS += -Wall -pipe -fno-exceptions -fno-rtti -fstrict-aliasing\r
++CXXFLAGS += -Wall -fno-exceptions -fno-rtti\r
+ ifndef NDEBUG\r
+-CXXFLAGS += -g -D_DEBUG\r
+-else\r
+-CXXFLAGS += -fexpensive-optimizations -O3\r
++CXXFLAGS += -D_DEBUG\r
+ endif\r
+ ifdef PROFILE\r
+ CXXFLAGS += -pg\r
+ endif\r
+-CFLAGS := -O3 -fexpensive-optimizations -DPNG_THREAD_UNSAFE_OK -DPNG_NO_MMX_CODE -DPNG_NO_MNG_FEATURES\r
++CFLAGS += -DPNG_THREAD_UNSAFE_OK -DPNG_NO_MMX_CODE -DPNG_NO_MNG_FEATURES\r
\r
+ sharedlib sharedlib_osx: CXXFLAGS += -fPIC\r
+ sharedlib sharedlib_osx: CFLAGS += -fPIC\r