Add games-action/supertuxkart-0.8.1. with patches
[shuber-gentoo-overlay.git] / games-action / supertuxkart / files / supertuxkart-0.8.1-gentoo.patch
diff --git a/games-action/supertuxkart/files/supertuxkart-0.8.1-gentoo.patch b/games-action/supertuxkart/files/supertuxkart-0.8.1-gentoo.patch
new file mode 100644 (file)
index 0000000..14a9d7f
--- /dev/null
@@ -0,0 +1,17 @@
+this is gentoo specific, because of unbundling Irrlicht dependencies
+
+--- CMakeLists.txt
++++ CMakeLists.txt
+@@ -196,7 +196,11 @@
+     ${IRRLICHT_LIBRARY}
+     ${IRRLICHT_XF86VM_LIBRARY}
+     ${OPENAL_LIBRARY}
+-    ${OPENGL_LIBRARIES})
++    ${OPENGL_LIBRARIES}
++    png
++    jpeg
++    bz2
++    z)
+ if(USE_FRIBIDI)
+     target_link_libraries(supertuxkart ${FRIBIDI_LIBRARIES})