add dev-tex/latexmk-430
[shuber-gentoo-overlay.git] / dev-tex / latexmk / latexmk-430.ebuild
diff --git a/dev-tex/latexmk/latexmk-430.ebuild b/dev-tex/latexmk/latexmk-430.ebuild
new file mode 100644 (file)
index 0000000..aae992f
--- /dev/null
@@ -0,0 +1,31 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tex/latexmk/latexmk-427a.ebuild,v 1.2 2011/11/02 15:33:18 aballier Exp $
+
+EAPI=4
+
+inherit bash-completion-r1
+
+DESCRIPTION="Perl script for automatically building LaTeX documents."
+HOMEPAGE="http://www.phys.psu.edu/~collins/software/latexmk/"
+SRC_URI="http://www.phys.psu.edu/~collins/software/latexmk/${P}.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~ppc-macos ~x64-macos ~x86-macos"
+IUSE=""
+
+RDEPEND="virtual/latex-base
+       dev-lang/perl"
+DEPEND="${RDEPEND}
+       app-arch/unzip"
+
+S=${WORKDIR}
+
+src_install() {
+       newbin latexmk.pl latexmk
+       doman latexmk.1
+       dodoc CHANGES README latexmk.pdf latexmk.ps latexmk.txt
+       dodoc -r example_rcfiles extra-scripts
+       newbashcomp "${FILESDIR}"/completion.bash-2 ${PN}
+}