dev-libs/core: Change to subversion
[shuber-gentoo-overlay.git] / dev-libs / core / core-2.1-r10975.ebuild
similarity index 82%
rename from dev-libs/core/core-2.1.ebuild
rename to dev-libs/core/core-2.1-r10975.ebuild
index e4083e0f4bc4b848d5d101ec6da2a2bc4ca6fbea..14a1c5760ab7573e0bbf08c0f6aa2e65ef544ae2 100644 (file)
@@ -4,9 +4,24 @@
 
 EAPI=5
 
+inherit subversion
+
 DESCRIPTION="Exact arithmetics library intended for exact geometric computations"
 HOMEPAGE="http://cs.nyu.edu/exact/core_pages/"
-SRC_URI="http://cs.nyu.edu/exact/core/download/core/${P}.std.tgz -> ${P}.tgz"
+
+# The "old style downloads" are no longer maintained
+ESVN_REPO_URI="https://subversive.cims.nyu.edu/exact/corelib2/trunk"
+ESVN_USER="guest"
+ESVN_PASSWORD="guest"
+ESVN_OPTIONS="--depth immediates"
+
+case ${PV} in
+       9999)
+               ;;
+       *)
+               ESVN_REVISION=${PR}
+               ;;
+esac
 
 LICENSE="QPL"
 SLOT="0"
@@ -57,7 +72,7 @@ src_compile() {
 
 
 src_install() {
-       
+
        dolib.a lib/libcore*.a
        if use shared; then
                dolib.so lib/libcore*.so
@@ -79,7 +94,7 @@ src_install() {
 
                docinto papers
                dodoc doc/papers/*
-               
+
                docinto html
                dodoc doc/doxy/html/*
        fi