dev-libs/core: Change to subversion
[shuber-gentoo-overlay.git] / dev-libs / core / core-2.1-r10975.ebuild
diff --git a/dev-libs/core/core-2.1-r10975.ebuild b/dev-libs/core/core-2.1-r10975.ebuild
new file mode 100644 (file)
index 0000000..14a1c57
--- /dev/null
@@ -0,0 +1,109 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+inherit subversion
+
+DESCRIPTION="Exact arithmetics library intended for exact geometric computations"
+HOMEPAGE="http://cs.nyu.edu/exact/core_pages/"
+
+# The "old style downloads" are no longer maintained
+ESVN_REPO_URI="https://subversive.cims.nyu.edu/exact/corelib2/trunk"
+ESVN_USER="guest"
+ESVN_PASSWORD="guest"
+ESVN_OPTIONS="--depth immediates"
+
+case ${PV} in
+       9999)
+               ;;
+       *)
+               ESVN_REVISION=${PR}
+               ;;
+esac
+
+LICENSE="QPL"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+RESTRICT="mirror"
+IUSE="debug doc extensions shared"
+
+DEPEND="
+       dev-libs/gmp
+       dev-libs/mpfr
+       doc? (
+               virtual/latex-base
+               app-doc/doxygen
+       )
+       "
+RDEPEND="${DEPEND}"
+S="${WORKDIR}/${P}.1"
+
+
+src_compile() {
+       export PLATFORM="gnu"
+       export LINKAGE="static"
+       if use shared; then
+               einfo "Add shared version"
+               LINKAGE="shared"
+       fi
+
+       emake corelib
+       if use extensions; then
+               emake corex
+       fi
+
+       if use debug; then
+               einfo "Compile debug version"
+               export VAR=Debug
+               emake corelib
+
+               if use extensions; then
+                       emake corex
+               fi
+       fi
+
+       if use doc; then
+               cd doc
+               emake
+       fi
+}
+
+
+src_install() {
+
+       dolib.a lib/libcore*.a
+       if use shared; then
+               dolib.so lib/libcore*.so
+       fi
+
+       dodoc README
+       dodoc FAQs
+
+
+       if use doc; then
+
+               dodoc doc/stackOverflow.txt
+               dodoc doc/bigNumFormat.txt
+               dodoc doc/eclipse.txt
+               dodoc doc/tutorial/tutorial.pdf
+
+               docinto announce
+               dodoc doc/announce/*
+
+               docinto papers
+               dodoc doc/papers/*
+
+               docinto html
+               dodoc doc/doxy/html/*
+       fi
+
+       insinto /usr/include/
+       cd inc
+       doins -r CORE
+}
+
+
+
+