Add app-pda/{ifuse,libimobiledevice}-9999
[shuber-gentoo-overlay.git] / app-pda / ifuse / ifuse-9999.ebuild
diff --git a/app-pda/ifuse/ifuse-9999.ebuild b/app-pda/ifuse/ifuse-9999.ebuild
new file mode 100644 (file)
index 0000000..38d58c9
--- /dev/null
@@ -0,0 +1,35 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit autotools readme.gentoo
+
+DESCRIPTION="Mount Apple iPhone/iPod Touch file systems for backup purposes"
+HOMEPAGE="http://www.libimobiledevice.org/"
+SRC_URI="https://github.com/libimobiledevice/${PN}/archive/master.zip -> ${PN}.zip"
+
+
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND=">=app-pda/libimobiledevice-1.1.4:=
+       >=app-pda/libplist-1.8:=
+       >=sys-fs/fuse-2.7.0"
+DEPEND="${RDEPEND}
+       virtual/pkgconfig"
+
+DOCS="AUTHORS NEWS README"
+
+DOC_CONTENTS="Only use this filesystem driver to create backups of your data.
+The music database is hashed, and attempting to add files will cause the
+iPod/iPhone to consider your database unauthorised.
+It will respond by wiping all media files, requiring a restore through iTunes."
+
+S="${WORKDIR}/${PN}-master"
+
+src_prepare() {
+       eautoreconf
+}