add pycarddav-0.5.1
[shuber-gentoo-overlay.git] / app-misc / pycarddav / pycarddav-0.5.1.ebuild
diff --git a/app-misc/pycarddav/pycarddav-0.5.1.ebuild b/app-misc/pycarddav/pycarddav-0.5.1.ebuild
new file mode 100644 (file)
index 0000000..a4073c9
--- /dev/null
@@ -0,0 +1,43 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="5"
+
+PYTHON_COMPAT=( python{2_6,2_7} )
+PYTHON_USE_WITH="sqlite"
+
+inherit distutils-r1
+
+MY_PN=pyCardDAV
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="pyCardDAV is a simple to use CardDAV CLI client with mutt
+support."
+HOMEPAGE="http://lostpackets.de/pycarddav/"
+SRC_URI="https://lostpackets.de/pycarddav/downloads/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+KEYWORDS="~x86 ~amd64"
+SLOT="0"
+IUSE=""
+
+DEPEND="dev-python/lxml
+        dev-python/requests
+        dev-python/urwid
+        dev-python/vobject
+        dev-python/pyxdg
+        virtual/python-argparse"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+EXAMPLES=( pycard.conf.sample )
+
+pkg_postinst() {
+    ewarn "Copy and edit the supplied pycard.conf.sample file"
+    ewarn "(default location is ~/.config/pycard/pycard.conf)."
+    ewarn "Beware that only you can access this file,"
+    ewarn "if you have untrusted users on your machine,"
+    ewarn "since the password is stored in cleartext."
+}