x11-apps/inputplug: Add 0.3, fixes and EAPI=7
[shuber-gentoo-overlay.git] / x11-apps / inputplug / inputplug-9999.ebuild
1 # Copyright 1999-2020 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 DESCRIPTION="XInput event monitor daemon"
7 HOMEPAGE="https://github.com/andrewshadura/inputplug"
8
9 if [ "${PV}" == "9999" ]; then
10 inherit git-r3
11 EGIT_REPO_URI="https://github.com/andrewshadura/${PN}"
12 else
13 SRC_URI="https://github.com/andrewshadura/${PN}/archive/${PV}.tar.gz"
14 fi
15
16 LICENSE="MIT"
17 SLOT="0"
18 KEYWORDS="~x86 ~amd64"
19 IUSE=""
20
21 DEPEND="
22 x11-libs/libXi
23 x11-libs/libxcb
24 "
25 RDEPEND="${DEPEND}"
26
27 src_install() {
28 dobin ${PN}
29 doman ${PN}.1
30 }