Add sci-mathematics/boolector
[shuber-gentoo-overlay.git] / sci-mathematics / boolector / boolector-1.5.116.ebuild
1 # Copyright 1999-2013 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=5
6 inherit eutils
7
8 DESCRIPTION="Boolector is an SMT solver for bit-vectors and arrays"
9 HOMEPAGE="http://fmv.jku.at/boolector/"
10 SRC_URI="http://fmv.jku.at/boolector/boolector-1.5.116-eeaf10b-121004.tar.gz"
11 S=${WORKDIR}/boolector-1.5.116-eeaf10b-121004
12
13 LICENSE="boolector"
14 SLOT="0"
15 KEYWORDS="~x86 ~amd64"
16 IUSE=""
17
18 DEPEND="
19 sci-mathematics/lingeling"
20 RDEPEND="${DEPEND}"
21
22 src_prepare() {
23 epatch ${FILESDIR}/pathfixes.patch
24 }
25
26 src_configure() {
27 ./configure --lingeling --no-picosat --no-minisat
28 }
29
30 src_install() {
31 dodoc NEWS VERSION
32 dobin boolector synthebtor deltabtor
33 dolib libboolector.a
34 doheader boolector.h
35 }