media-video/v4l2loopback: Fix URLs and Manifest
[shuber-gentoo-overlay.git] / net-im / teams-bin / teams-bin-1.3.00.958.ebuild
1 # Copyright 2019-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit unpacker xdg
7
8 MY_PN="${PN/-bin}"
9
10 DESCRIPTION="Microsoft Teams for Linux is your chat-centered workspace in Office 365"
11 HOMEPAGE="https://teams.microsoft.com/downloads"
12 SRC_URI="
13 amd64? ( https://packages.microsoft.com/repos/ms-${MY_PN}/pool/main/${PN:0:1}/${MY_PN}/${MY_PN}_${PV}_amd64.deb )"
14
15 LICENSE="Ms-PL"
16 SLOT="0"
17 KEYWORDS="~amd64"
18 RESTRICT="mirror strip"
19
20 RDEPEND="
21 app-crypt/libsecret
22 dev-libs/nss
23 media-libs/alsa-lib
24 >=sys-libs/glibc-2.28-r4
25 x11-libs/gtk+:3
26 x11-libs/libXScrnSaver
27 x11-libs/libXtst
28 !net-im/teams"
29 DEPEND="${RDEPEND}"
30
31 S="${WORKDIR}"
32
33 src_unpack() {
34 unpack_deb "${A}"
35 }
36
37 src_prepare() {
38 rm _gpgorigin || die
39 default
40 }
41
42 src_install() {
43 mkdir -p "${ED}"
44 cp -r . "${ED}/"
45 }