media-gfx/cgal-ipelets: Add cgal-ipelets-5.6
[shuber-gentoo-overlay.git] / media-libs / libspiro / libspiro-20200505.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 if [[ -z ${PV%%*9999} ]]; then
7 inherit git-r3
8 EGIT_REPO_URI="https://github.com/fontforge/${PN}.git"
9 else
10 MY_PV="${PV}"
11 if [[ -z ${PV%%*_p*} ]]; then
12 inherit vcs-snapshot
13 MY_PV="8c7a31e"
14 fi
15 SRC_URI="
16 https://github.com/fontforge/${PN}/archive/refs/tags/${MY_PV}.tar.gz -> ${P}.tar.gz
17 "
18 RESTRICT="primaryuri"
19 KEYWORDS="~amd64 ~x86"
20 fi
21 inherit autotools
22
23 DESCRIPTION="A library for drawing beautiful curves"
24 HOMEPAGE="https://github.com/fontforge/libspiro"
25
26 LICENSE="GPL-3+"
27 SLOT="0"
28 IUSE=""
29
30 DEPEND=""
31 RDEPEND="${DEPEND}"
32
33 src_prepare() {
34 default
35 eautoreconf
36 }