media-gfx/svgtoipe: Switch to python-3.6
[shuber-gentoo-overlay.git] / media-gfx / svgtoipe / svgtoipe-9999.ebuild
1 # Distributed under the terms of the GNU General Public License v2
2 # $Header: $
3
4 EAPI=6
5
6 PYTHON_COMPAT=( python3_6 )
7 inherit git-r3 python-single-r1
8
9 DESCRIPTION="Converts SVG files to Ipe xml files"
10 HOMEPAGE="https://github.com/otfried/ipe-tools/tree/master/figtoipe"
11 EGIT_REPO_URI="https://github.com/otfried/ipe-tools.git"
12 SRC_URI=""
13
14 LICENSE="GPL-3"
15 SLOT="0"
16 KEYWORDS="~amd64 ~x86"
17 IUSE=""
18
19 DEPEND="|| ( dev-lang/python:3.6[xml] )"
20 RDEPEND="${DEPEND}"
21
22 BASEDIR="${WORKDIR}/${P}/${PN}"
23
24 src_install() {
25 cd ${BASEDIR}
26 python_fix_shebang .
27
28 mv ${PN}.py ${PN}
29 exeinto /usr/bin/
30 doexe ${PN}
31 doman ${PN}.1
32 }
33
34