Add geogebra-4.1.120.0
[shuber-gentoo-overlay.git] / media-gfx / pdftoipe / pdftoipe-20110916-r2.ebuild
1 # Copyright 1999-2010 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=3
6
7 inherit eutils
8
9 DESCRIPTION="Converts pdf files to Ipe xml files"
10 HOMEPAGE="http://ipe7.sourceforge.net/"
11 PEXT="${P}-src"
12 SRC_URI="http://sourceforge.net/projects/ipe7/files%2Ftools%2F${PEXT}.tar.gz/download
13 -> ${P}.tar.gz"
14
15
16 LICENSE="GPL-3"
17 SLOT="0"
18 KEYWORDS="~amd64 ~x86"
19 RESTRICT="mirror"
20 IUSE=""
21 S="${WORKDIR}/${PEXT}"
22
23 DEPEND="app-text/poppler
24 >=media-gfx/ipe-7.0.0"
25 RDEPEND="${DEPEND}"
26
27
28 src_prepare() {
29 epatch "${FILESDIR}"/poppler-0.18.patch || die
30 epatch "${FILESDIR}"/poppler-0.20.patch || die
31 }
32
33 src_compile() {
34 emake || die
35 }
36
37 src_install() {
38 exeinto /usr/bin/
39 doexe $S/pdftoipe
40 doman $S/pdftoipe.1
41 dodoc $S/readme.txt
42 }
43
44