ipe-7.1.3: adapt to dev-qt/* packages
[shuber-gentoo-overlay.git] / media-gfx / ipe / ipe-7.1.3.ebuild
1 # Distributed under the terms of the GNU General Public License v2
2 # $Header: $
3
4 EAPI=4
5 inherit eutils toolchain-funcs qt4-r2
6
7 DESCRIPTION="Drawing editor for creating figures in PDF or PS formats"
8 HOMEPAGE="http://ipe7.sourceforge.net/"
9 SRC_URI="mirror://sourceforge/ipe7/${PN}/7.1.0/${P}-src.tar.gz"
10
11 LICENSE="GPL-3"
12 SLOT="0"
13 KEYWORDS="~amd64 ~x86"
14 IUSE="highprec"
15
16 RDEPEND="app-text/texlive-core
17 dev-lang/lua
18 media-libs/freetype:2
19 x11-libs/cairo
20 dev-qt/qtcore:4
21 dev-qt/qtgui:4"
22 DEPEND="${RDEPEND}
23 virtual/pkgconfig"
24
25 S="${WORKDIR}/${P}/src"
26 COMMONDIR=/usr/share/ipe/common
27
28 search_urw_fonts() {
29 # colon-separated list of paths
30 local texmfdist="$(kpsewhich -var-value=TEXMFDIST)"
31 # according to TeX directory structure
32 local urwdir=fonts/type1/urw
33 # add colon as field separator
34 local IFS="${IFS}:" dir
35 for dir in ${texmfdist}; do
36 if [[ -d ${dir}/${urwdir} ]]; then
37 URWFONTDIR="${dir}/${urwdir}"
38 return 0
39 fi
40 done
41 return 1
42 }
43
44 src_prepare() {
45 if use highprec; then
46 einfo "Adding patch for higher output precision"
47 epatch "${FILESDIR}"/${PN}-outputprecision.patch
48 fi
49 }
50
51 pkg_setup() {
52 if search_urw_fonts; then
53 einfo "URW fonts found in ${URWFONTDIR}"
54 else
55 ewarn "Could not find directory containing URW fonts"
56 ewarn "Ipe will not function properly without them."
57 fi
58 }
59
60 src_prepare() {
61 sed -i \
62 -e 's/fpic/fPIC/' \
63 -e 's/moc-qt4/moc/' \
64 -e "s:\$(IPEPREFIX)/lib:\$(IPEPREFIX)/$(get_libdir):g" \
65 config.mak || die
66 sed -i -e 's/install -s/install/' common.mak || die
67
68 }
69
70 src_compile() {
71 emake \
72 CXX=$(tc-getCXX) \
73 IPEPREFIX="${EPREFIX}/usr" \
74 IPEDOCDIR="${EPREFIX}/usr/share/doc/${PF}/html"
75 }
76
77 src_install() {
78 emake install \
79 IPEPREFIX="${EPREFIX}/usr" \
80 IPEDOCDIR="${EPREFIX}/usr/share/doc/${PF}/html" \
81 INSTALL_ROOT="${ED}"
82 dodoc ../{news,readme}.txt
83 doicon ipe/icons/ipe.png
84 make_desktop_entry ipe Ipe ipe
85 # Link style sheets
86 if [ -d $COMMONDIR/styles ]; then
87 einfo "Linking common style sheets from $COMMONDIR"
88 for f in $COMMONDIR/styles/*; do
89 einfo " Linking ${f##*/}"
90 dosym $f usr/share/ipe/${PV}/styles/${f##*/}
91 done
92
93 elog "Style sheets from $COMMONDIR/styles have been symlinked to"
94 elog "the style sheet directory of ${P}. If you add additional"
95 elog "style sheets later to $COMMONDIR/styles you may symlink"
96 elog "them by hand to '/usr/share/ipe/${PV}/styles/'."
97 fi
98 }