media-gfx/cgal-ipelets: Add cgal-ipelets-5.2
[shuber-gentoo-overlay.git] / media-gfx / cgal-ipelets / cgal-ipelets-5.2.ebuild
1 # Distributed under the terms of the GNU General Public License v2
2 # $Header: $
3
4 EAPI=7
5
6 CMAKE_BUILD_TYPE=Release
7
8 inherit multilib cmake-utils
9
10 MY_P=CGAL-${PV}
11
12 DESCRIPTION="Ipe addons shipped with the CGAL library"
13 HOMEPAGE="http://www.cgal.org/ https://gforge.inria.fr/projects/cgal/"
14 SRC_URI="https://github.com/CGAL/cgal/releases/download/v${PV}/${MY_P}.tar.xz"
15
16 LICENSE="LGPL-3 GPL-3 Boost-1.0"
17 SLOT="0"
18 KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
19 IUSE=""
20
21 DEPEND="
22 media-gfx/ipe
23 ~sci-mathematics/cgal-${PV}
24 "
25 RDEPEND="${DEPEND}"
26
27 S="${WORKDIR}/${MY_P}/demo/CGAL_ipelets"