Add ipe-7.2.3
[shuber-gentoo-overlay.git] / media-gfx / cgal-ipelets / cgal-ipelets-4.6.1.ebuild
1 # Distributed under the terms of the GNU General Public License v2
2 # $Header: $
3
4 EAPI=4
5
6 CMAKE_BUILD_TYPE=Release
7
8 inherit base multilib cmake-utils
9
10 MY_P=CGAL-${PV}
11 PID=34900
12
13 DESCRIPTION="Ipe addons shipped with the CGAL library"
14 HOMEPAGE="http://www.cgal.org/ https://gforge.inria.fr/projects/cgal/"
15 SRC_URI="http://gforge.inria.fr/frs/download.php/${PID}/${MY_P}.tar.xz"
16
17 LICENSE="LGPL-3 GPL-3 Boost-1.0"
18 SLOT="0"
19 KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
20 IUSE=""
21
22 DEPEND="
23 media-gfx/ipe
24 =sci-mathematics/cgal-4.6*
25 "
26 RDEPEND="${DEPEND}"
27
28 S="${WORKDIR}/${MY_P}/demo/CGAL_ipelets"
29
30 src_prepare() {
31 cmake-utils_src_prepare
32 epatch ${FILESDIR}/c++11.patch
33 }