Add dev-util/stack
[shuber-gentoo-overlay.git] / dev-util / stack / stack-9999.ebuild
1 # Copyright 1999-2013 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=5
6
7 DESCRIPTION="STACK is a static checker that detects unstable code in C/C++ programs"
8 HOMEPAGE="http://css.csail.mit.edu/stack/"
9 SRC_URI="https://github.com/xiw/stack/archive/master.zip -> stack-master.zip"
10 S="${WORKDIR}/${PN}-master"
11
12 LICENSE="MIT"
13 SLOT="0"
14 KEYWORDS="~amd64 ~x86"
15 IUSE=""
16
17 DEPEND="
18 sys-devel/clang
19 >sys-devel/llvm-3.3.9999"
20 RDEPEND="${DEPEND}"
21
22 src_configure() {
23 autoreconf -fvi
24 econf
25 }
26
27 src_install() {
28 default
29
30 dobin src/ncpu
31 dobin src/optck
32 dobin src/poptck
33 dobin test/stack-build
34
35 exeinto /usr/bin/stack
36 doexe test/arm-linux-gnueabi-g++
37 doexe test/arm-linux-gnueabi-gcc
38 doexe test/cc1
39 doexe test/gcc
40
41 into /usr/bin/stack
42 dosym ${DESTTREE}/gcc ${DESTTREE}/c++
43 dosym ${DESTTREE}/gcc ${DESTTREE}/cc
44 dosym ${DESTTREE}/gcc ${DESTTREE}/clang
45 dosym ${DESTTREE}/gcc ${DESTTREE}/clang++
46 dosym ${DESTTREE}/gcc ${DESTTREE}/g++
47 }