add dev-util/edb
[shuber-gentoo-overlay.git] / dev-util / edb / edb-0.9.17.ebuild
1 # Copyright 1999-2007 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit eutils multilib
6
7 DESCRIPTION="EDB \"Evan's Debugger\" (OllyDbg workalike for Linux)"
8 HOMEPAGE="http://www.codef00.com/projects#debugger"
9 SRC_URI="http://www.codef00.com/projects/debugger-${PV}.tgz"
10 LICENSE="GPL-2"
11 SLOT="0"
12 KEYWORDS="~x86 ~amd64"
13 IUSE=""
14 RESTRICT="strip mirror"
15
16 DEPEND="
17 >=x11-libs/qt-core-4.5.0
18 >=x11-libs/qt-gui-4.5.0
19 >=dev-libs/boost-1.35.0"
20
21 RDEPEND="${DEPEND}"
22 S="${WORKDIR}/debugger"
23
24 src_compile() {
25 qmake -makefile DEFAULT_PLUGIN_PATH="/usr/$(get_libdir)/edb/" || dir "qmake failed"
26 emake || die "emake failed"
27 }
28
29 src_install() {
30 make INSTALL_ROOT=${D}/usr/ install
31 dodoc CHANGELOG README README.plugins
32 doman edb.1
33 }
34
35 pkg_postinst() {
36 einfo "Note: EBD's plugins are installed by default into /usr/$(get_libdir)/edb."
37 einfo "If you have previously used EDB and have it set to look in a"
38 einfo "different directory, then you will need to adjust this. Also"
39 einfo "EDB looks for plugins in the current working directory as well"
40 einfo "as the directory specified in the options, so that unpriviledged"
41 einfo "users can use plugins not installed system wide."
42 }