media-gfx/ipe: Add ipe-7.2.11
[shuber-gentoo-overlay.git] / dev-libs / core / core-2.1.ebuild
1 # Copyright 1999-2010 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=5
6
7 DESCRIPTION="Exact arithmetics library intended for exact geometric computations"
8 HOMEPAGE="http://cs.nyu.edu/exact/core_pages/"
9 SRC_URI="http://cs.nyu.edu/exact/core/download/core/${P}.std.tgz -> ${P}.tgz"
10
11 LICENSE="QPL"
12 SLOT="0"
13 KEYWORDS="~x86 ~amd64"
14 RESTRICT="mirror"
15 IUSE="debug doc extensions shared"
16
17 DEPEND="
18 dev-libs/gmp
19 dev-libs/mpfr
20 doc? (
21 virtual/latex-base
22 app-doc/doxygen
23 )
24 "
25 RDEPEND="${DEPEND}"
26 S="${WORKDIR}/${P}.1"
27
28
29 src_compile() {
30 export PLATFORM="gnu"
31 export LINKAGE="static"
32 if use shared; then
33 einfo "Add shared version"
34 LINKAGE="shared"
35 fi
36
37 emake corelib
38 if use extensions; then
39 emake corex
40 fi
41
42 if use debug; then
43 einfo "Compile debug version"
44 export VAR=Debug
45 emake corelib
46
47 if use extensions; then
48 emake corex
49 fi
50 fi
51
52 if use doc; then
53 cd doc
54 emake
55 fi
56 }
57
58
59 src_install() {
60
61 dolib.a lib/libcore*.a
62 if use shared; then
63 dolib.so lib/libcore*.so
64 fi
65
66 dodoc README
67 dodoc FAQs
68
69
70 if use doc; then
71
72 dodoc doc/stackOverflow.txt
73 dodoc doc/bigNumFormat.txt
74 dodoc doc/eclipse.txt
75 dodoc doc/tutorial/tutorial.pdf
76
77 docinto announce
78 dodoc doc/announce/*
79
80 docinto papers
81 dodoc doc/papers/*
82
83 docinto html
84 dodoc doc/doxy/html/*
85 fi
86
87 insinto /usr/include/
88 cd inc
89 doins -r CORE
90 }
91
92
93
94