media-gfx/cgal-ipelets: Add cgal-ipelets-5.6
[shuber-gentoo-overlay.git] / dev-libs / core / core-2.1-r10975.ebuild
1 # Copyright 1999-2010 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=7
6
7 inherit subversion
8
9 DESCRIPTION="Exact arithmetics library intended for exact geometric computations"
10 HOMEPAGE="http://cs.nyu.edu/exact/core_pages/"
11
12 # The "old style downloads" are no longer maintained
13 ESVN_REPO_URI="https://subversive.cims.nyu.edu/exact/corelib2/trunk"
14 ESVN_USER="guest"
15 ESVN_PASSWORD="guest"
16 ESVN_OPTIONS="--depth immediates"
17
18 case ${PV} in
19 9999)
20 ;;
21 *)
22 ESVN_REVISION=${PR}
23 ;;
24 esac
25
26 LICENSE="QPL"
27 SLOT="0"
28 KEYWORDS="~x86 ~amd64"
29 RESTRICT="mirror"
30 IUSE="debug doc extensions shared"
31
32 DEPEND="
33 dev-libs/gmp
34 dev-libs/mpfr
35 doc? (
36 virtual/latex-base
37 app-doc/doxygen
38 )
39 "
40 RDEPEND="${DEPEND}"
41 S="${WORKDIR}/${P}.1"
42
43
44 src_compile() {
45 export PLATFORM="gnu"
46 export LINKAGE="static"
47 if use shared; then
48 einfo "Add shared version"
49 LINKAGE="shared"
50 fi
51
52 emake corelib
53 if use extensions; then
54 emake corex
55 fi
56
57 if use debug; then
58 einfo "Compile debug version"
59 export VAR=Debug
60 emake corelib
61
62 if use extensions; then
63 emake corex
64 fi
65 fi
66
67 if use doc; then
68 cd doc
69 emake
70 fi
71 }
72
73
74 src_install() {
75
76 dolib.a lib/libcore*.a
77 if use shared; then
78 dolib.so lib/libcore*.so
79 fi
80
81 dodoc README
82 dodoc FAQs
83
84
85 if use doc; then
86
87 dodoc doc/stackOverflow.txt
88 dodoc doc/bigNumFormat.txt
89 dodoc doc/eclipse.txt
90 dodoc doc/tutorial/tutorial.pdf
91
92 docinto announce
93 dodoc doc/announce/*
94
95 docinto papers
96 dodoc doc/papers/*
97
98 docinto html
99 dodoc doc/doxy/html/*
100 fi
101
102 insinto /usr/include/
103 cd inc
104 doins -r CORE
105 }
106
107
108
109