use.local.desc: Add ipe-tools use flags
[shuber-gentoo-overlay.git] / app-misc / khard / khard-0.15.1.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5 PYTHON_COMPAT=( python3_{5,6,7} )
6 inherit distutils-r1
7 DESCRIPTION="Console CardDAV client"
8 HOMEPAGE="https://github.com/scheibler/khard"
9 LICENSE="GPL-3"
10 SLOT="0"
11 IUSE="test zsh-completion"
12
13 if [ "${PV}" == "9999" ]; then
14 inherit git-r3
15 EGIT_REPO_URI="https://github.com/scheibler/khard"
16 else
17 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
18 KEYWORDS="amd64 ~arm64"
19 fi
20
21 RDEPEND="
22 dev-python/atomicwrites[${PYTHON_USEDEP}]
23 dev-python/configobj[${PYTHON_USEDEP}]
24 dev-python/ruamel-yaml[${PYTHON_USEDEP}]
25 dev-python/unidecode[${PYTHON_USEDEP}]
26 >dev-python/vobject-0.9.3[${PYTHON_USEDEP}]
27 "
28 DEPEND="
29 dev-python/setuptools[${PYTHON_USEDEP}]
30 test? (
31 ${RDEPEND}
32 )
33 "
34 # vobject-0.9.3 breaks khard, see
35 # https://github.com/scheibler/khard/issues/87
36 # https://github.com/eventable/vobject/issues/39
37
38 DOCS=( AUTHORS CHANGES README.md misc/khard/khard.conf.example )
39
40 src_install() {
41 distutils-r1_src_install
42
43 if use zsh-completion; then
44 insinto /usr/share/zsh/site-functions
45 doins misc/zsh/_khard
46 fi
47 }
48
49 python_test() {
50 esetup.py test
51 }