* Debian package: small cleanups.
[pgp-tools.git] / debian / rules
index 12f7677759bd5e8fcdd9802e82245e18884876a4..b863c7348db5919684c3ca58a6242561bb6b696b 100755 (executable)
@@ -1,7 +1,5 @@
 #!/usr/bin/make -f
 
-include /usr/share/quilt/quilt.make
-
 VERSION := $(shell dpkg-parsechangelog | grep ^Version | cut -d' ' -f2)
 
 INSTALL             = install
@@ -23,13 +21,15 @@ configure-stamp:
        dh_testdir
        touch $@
 
-build: build-stamp
-build-stamp: $(QUILT_STAMPFN) configure-stamp
+build: build-arch build-indep
+build-arch: build-stamp
+build-indep: build-stamp
+build-stamp: configure-stamp
        dh_testdir
        $(MAKE)
        touch $@
 
-clean: unpatch
+clean:
        dh_testdir
        dh_testroot
        $(MAKE) clean
@@ -39,7 +39,7 @@ clean: unpatch
 install: build
        dh_testdir
        dh_testroot
-       dh_clean -k
+       dh_prep
        dh_installdirs
        $(MAKE) install DESTDIR=$(DESTDIR)
        dh_install
@@ -57,10 +57,10 @@ install: build
        $(INSTALL_PROGRAM) $(GPGWRAP_DIR)/$(GPGWRAP_PROG) $(DESTDIR_BIN)                
        $(INSTALL_DATA) $(GPGWRAP_DIR)/NEWS $(DESTDIR_DOC)/changelog.gpgwrap
        
-       # ignore errors with older debhelper versions
-       -dh_lintian
+       dh_lintian
 
 binary-indep: build install
+binary-arch: build install
        dh_testdir
        dh_testroot
        dh_installdocs
@@ -78,8 +78,6 @@ binary-indep: build install
        dh_md5sums
        dh_builddeb
 
-# Build architecture-dependent files here.
-binary-arch: build install
+binary: binary-indep binary-arch
 
-binary: binary-indep
 .PHONY: build clean binary-indep binary-arch binary install configure