Added Quilt framework.
[pgp-tools.git] / debian / rules
index a592123becd0ac9ab6c61fc55b196e5444ebc9b6..a660382436995bfd4fbb803bcc60468f4b1a1b41 100755 (executable)
@@ -1,5 +1,7 @@
 #!/usr/bin/make -f
 
+include /usr/share/quilt/quilt.make
+
 VERSION := $(shell dpkg-parsechangelog | grep ^Version | cut -d' ' -f2)
 
 configure: configure-stamp
@@ -8,12 +10,12 @@ configure-stamp:
        touch $@
 
 build: build-stamp
-build-stamp: configure-stamp
+build-stamp: $(QUILT_STAMPFN) configure-stamp
        dh_testdir
        $(MAKE)
        touch $@
 
-clean:
+clean: unpatch
        dh_testdir
        dh_testroot
        $(MAKE) clean
@@ -46,6 +48,7 @@ binary-indep: build install
        dh_installcron
        dh_installinfo
        dh_installchangelogs
+       dh_strip
        dh_compress
        dh_fixperms
        dh_installdeb