Installed gpgwrap from d.rules for consistency purpose.
[pgp-tools.git] / debian / patches / gpgwrap_makefile.diff
index 51930f1d321e86183dfe61b8d0189d570a6dad70..114dd01dd2b3f8e40a3349c4a750322670733232 100644 (file)
@@ -1,24 +1,36 @@
 From: Franck Joncourt <franck.mail@dthconnex.com>
 Subject: [PATCH] fixes/gpgwrap_makefile
 
-This allows gpgwrap to be installed with the main Makefile.
+This allows the main Makefile not to fail when trying to install gpgwrap.
+It just adds the install target in the gpgwrap Makefile.
+
+That could be avoided by handling differently the gpgwrap project in the main
+Makefile, but then it is going to be the mess.
+
+The new target does not install anything since so far the man page is currently
+installed from debian/rules, and thus everything to install gpgwrap is added to
+debian.rules for consistency purpose.
 
 Signed-off-by: Franck Joncourt <franck.mail@dthconnex.com>
 
 ---
- gpgwrap/Makefile |    3 +++
- 1 files changed, 3 insertions(+), 0 deletions(-)
+ gpgwrap/Makefile |    4 +++-
+ 1 files changed, 3 insertions(+), 1 deletions(-)
 
 diff --git a/gpgwrap/Makefile b/gpgwrap/Makefile
-index 30064df..ff6ead2 100644
+index 30064df..3dc65b9 100644
 --- a/gpgwrap/Makefile
 +++ b/gpgwrap/Makefile
-@@ -5,5 +5,8 @@ MAKE=make
+@@ -1,9 +1,11 @@
+ MAKE=make
+-.PHONY: all clean
++.PHONY: all clean install
  all:
        cd src && ${MAKE} all DIET="${DIET}"
  
 +install:
-+      install bin/gpgwrap $(DESTDIR)/usr/bin
 +
  clean:
        cd src && ${MAKE} clean