]> git.sthu.org Git - shuber-gentoo-overlay.git/commitdiff
app-text/shrinkpdf: Add app-text/shrinkpdf-9999
authorStefan Huber <shuber@sthu.org>
Wed, 31 Jul 2024 06:02:34 +0000 (08:02 +0200)
committerStefan Huber <shuber@sthu.org>
Wed, 31 Jul 2024 06:02:34 +0000 (08:02 +0200)
app-text/shrinkpdf/Manifest [new file with mode: 0644]
app-text/shrinkpdf/shrinkpdf-9999.ebuild [new file with mode: 0644]

diff --git a/app-text/shrinkpdf/Manifest b/app-text/shrinkpdf/Manifest
new file mode 100644 (file)
index 0000000..123417b
--- /dev/null
@@ -0,0 +1 @@
+EBUILD shrinkpdf-9999.ebuild 862 BLAKE2B 72c434cb6ac88861810646d74d359296ec97e64914fb7d60e8c0a8125aa8603d0c8ddcbdc6e8c4f06871f52f6cde04063bb6782ec4fafd5d1094cff8a05f1274 SHA512 8fd2fb22a0b06b64078759aedc9602d5d43195f7f8ba314d57f13da8d72b65a98af66a6146abb05c8af8ea95eec999666da2e4d4d986560326eb00573c670f12
diff --git a/app-text/shrinkpdf/shrinkpdf-9999.ebuild b/app-text/shrinkpdf/shrinkpdf-9999.ebuild
new file mode 100644 (file)
index 0000000..65f5c63
--- /dev/null
@@ -0,0 +1,40 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+#COMMIT_ID=""
+
+DESCRIPTION="Presenter console with multi-monitor support for PDF files"
+HOMEPAGE="https://pdfpc.github.io https://github.com/pdfpc/pdfpc"
+GITHUBUSER="aklomp"
+
+if [[ ${PV} == *9999 ]]; then
+       EGIT_REPO_URI="https://github.com/${GITHUBUSER}/${PN}.git"
+       inherit git-r3
+elif [[ ${PV} == *_p* ]]; then
+       SRC_URI="https://github.com/${GITHUBUSER}/${PN}/archive/${COMMIT_ID}.tar.gz -> ${P}.tar.gz"
+       S="${WORKDIR}/${PN}-${COMMIT_ID}"
+else
+       SRC_URI="https://github.com/${GITHUBUSER}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="
+       app-text/ghostscript-gpl
+"
+DEPEND="${RDEPEND}"
+BDEPEND=""
+
+src_prepare() {
+       default
+       mv shrinkpdf.sh shrinkpdf
+}
+
+src_install() {
+       dobin shrinkpdf
+}