]> git.sthu.org Git - shuber-gentoo-overlay.git/commitdiff
Add python-3.13 support
authorStefan Huber <shuber@sthu.org>
Tue, 6 May 2025 18:17:17 +0000 (20:17 +0200)
committerStefan Huber <shuber@sthu.org>
Tue, 6 May 2025 18:17:24 +0000 (20:17 +0200)
dev-db/sqlite3-pcre/Manifest
dev-db/sqlite3-pcre/sqlite3-pcre-20070120.ebuild
dev-debug/gdb-dashboard/Manifest [new file with mode: 0644]
dev-debug/gdb-dashboard/gdb-dashboard-0.17.4.ebuild [new file with mode: 0644]
media-gfx/ipe-tools/Manifest
media-gfx/ipe-tools/ipe-tools-7.2.20.1.ebuild [deleted file]
media-gfx/ipe-tools/ipe-tools-7.2.24.1.ebuild

index 04929512434b0716bc19a20605532b6426e6596f..f9030c32ee0d72e4431ddbaa690eb3dc045f58b8 100644 (file)
@@ -1,4 +1,4 @@
 AUX Makefile 357 BLAKE2B b900d7341fd31d90cda6e9efd0391ff530d6c6a6714ecb0b6d02dfe6283f49213e2f76a0cf744180948ecfafd29c094fcf534988e3c03add57090fd5ac9ee2fe SHA512 9bf1cf48e7709cc6211de02432c5de2f27f6a045ab6795b7e18490c94abc0fba06396f3f86cd114fc280de86caa5cc5ae04c0dd44114d6709c27f7b5a29b9eaa
 DIST sqlite3-pcre_0~git20070120091816+4229ecc.orig.tar.gz 1920 BLAKE2B 6ab3075ec17862e3080d68bf9067b559c4f268ce28a332176989e6d11b5faaf387cb3baa5461b86377fcfe5c464ef3a329cd3f740122028262824ea9964bb78c SHA512 48972742bfa3c1ab67cf82911d8c454afa0650acaa5e23608292eaa1833e52409e85452cf6e93af7caf0d15df74a6254195caa14dbe8b6751ce2e19da51a0c2a
-EBUILD sqlite3-pcre-20070120.ebuild 556 BLAKE2B 3d1651ba64bdecc9052f114ea0150a8346bf054910361e39fc6fa11a72c0d2d880ecab718a52aded5b85561fb69a1d39e2a49109699e41663a01a1886659b7e5 SHA512 65611293e587a8a1d3b49e99c99ddf7036d758bfabff793ed958eb0b4fd5f53d908cf921f53a681b8f3601c124dd0f5b8a51d4b49805ba23c6d8fddf05044f10
+EBUILD sqlite3-pcre-20070120.ebuild 577 BLAKE2B d490b1149c303871167613496369af568884eb15157d9b2c0c33e3908d753ae92987414abc362afe30a3e2e6273560425c37f5264fc57a92468f100393d34ed3 SHA512 0db9fb965c13cc48dd60b2a4dc54d501ebc41190ddb09edd9dec5487f7a47e0e3e9e460d9cd53f8ae04ae8a1345e9399e0768a33d20754ce8167f09c78278889
 MISC metadata.xml 243 BLAKE2B 889d08efb220a9fb8457500f5f3c33c8c737616995e19fa8b621ced4bc9d380d016413d098d4d09925c679cd23f7fbd75e495424fe6ed809a9e873014caae682 SHA512 f9051a65d7e11d7abd1b9568dbbf8be84a6ae68eb994b0c22d57dff5620047d5ad5a324057a5cf4cec10837d16024e5f21a8cf5f1a6247807f62931839eb73bc
index 73d9bb4984f0721d826141a483738e7111065dfc..a74bd0d4bea2eafef04b651fdcdcbe0cff4a8078 100644 (file)
@@ -17,5 +17,5 @@ DEPEND="${RDEPEND}"
 S="${WORKDIR}/${PN}"
 
 src_prepare() {
-       cp "${FILESDIR}/Makefile" "${S}/"
+       cp "${FILESDIR}/Makefile" "${S}/" || die "eapply_user"
 }
diff --git a/dev-debug/gdb-dashboard/Manifest b/dev-debug/gdb-dashboard/Manifest
new file mode 100644 (file)
index 0000000..de9c2d8
--- /dev/null
@@ -0,0 +1,2 @@
+DIST gdb-dashboard-0.17.4.tar.gz 23332 BLAKE2B cf05fea4c3d722d1bafbc6ef4a26df88be555be6adf8dca313ef9b8b28cad533931d3d2da0cb2660c1233c3b3e744a518893698ecbb1e573e12812cebfc3e7c8 SHA512 9cce63be926d21aace0833b52b36266f115599fbbf426dcd7d8090a6861c1c9db26fe7d953bedcbec0b96b75c9b2b9af59666c0e80f5cdf55bd6d44523459dbd
+EBUILD gdb-dashboard-0.17.4.ebuild 1282 BLAKE2B b114ebb72eb99e7b849a6c293b1adf3c40e8f5af7abfffbfab87fb56339f7c77a9fab78b3f990bbe67b8f89cf25686ce1aaa7c0b4ba3752ba2096e895e78fb25 SHA512 8ed1fecfb6ed51f322b8bc37f5c23bae16a4999b703c28b18c66a37718835f16ff4131d405806ffed516a2b92ccc09bb546ca71369362f9f06f2bf80ce8074fd
diff --git a/dev-debug/gdb-dashboard/gdb-dashboard-0.17.4.ebuild b/dev-debug/gdb-dashboard/gdb-dashboard-0.17.4.ebuild
new file mode 100644 (file)
index 0000000..89f2118
--- /dev/null
@@ -0,0 +1,53 @@
+# Copyright 2023-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{11..13} )
+
+inherit python-single-r1 optfeature wrapper
+
+DESCRIPTION="Modular visual interface for GDB in Python"
+HOMEPAGE="https://github.com/cyrus-and/gdb-dashboard"
+
+if [[ ${PV} == *9999 ]]; then
+       inherit git-r3
+       EGIT_REPO_URI="https://github.com/cyrus-and/gdb-dashboard"
+else
+       SRC_URI="https://github.com/cyrus-and/gdb-dashboard/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+       KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="
+       dev-debug/gdb[python]
+       ${PYTHON_DEPS}
+"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+pkg_setup() {
+       python-single-r1_pkg_setup
+}
+
+src_install() {
+       insinto "/usr/share/${PN}"
+       newins .gdbinit "${PN}"
+
+       # install a convenient wrapper. disables any typical .gdbinit (-nh) to
+       # get a clean state without interference. -q to disable annoying
+       # copyright message at startup.
+       make_wrapper "$PN" "gdb -q -nh -iex 'source /usr/share/${PN}/${PN}'"
+
+       dodoc README.md
+}
+
+pkg_postinst() {
+       einfo "To use ${PN}:"
+       einfo "    Either use the installed '${PN}' wrapper script directly."
+       einfo "    Or put 'source /usr/share/${PN}/${PN}' in your .gdbinit file."
+       einfo ""
+
+       optfeature "syntax highlighting" "dev-python/pygments"
+}
index 55c91715f3fd762bd5471ad3229da148ced99c7f..db175918ca71bdb4520c0549a22d51b4478cde8d 100644 (file)
@@ -1,5 +1,3 @@
-DIST v7.2.20.1.tar.gz 238820 BLAKE2B 3e85ed58252a0c242c4fcab05123fea7e62fb4bd577a1bcad5c48b83d9a4a6667fee5a1a46d0d45f2b89b9d2ce094ace6578924b63b1bccf5f519d7565828d09 SHA512 88533a0c13740201716939d567b5c6ca1fa3ddf16c58d3c1fd7db5d54faf8d1f8d3d788548284ee982bd510b565ed8c6e699f3eb47c27ba17522b4360154d3ce
 DIST v7.2.24.1.tar.gz 239300 BLAKE2B f853a0362fa7736cec0cca2a06ca409459552c70a8be1a567e5b21c9476e308305dfe35ce3be08f515d9ab340b388b8b32b23288d999918e9705a6370ddb77b3 SHA512 d12d35df3602fc0c0f0103377ed7b5ee7f0ca6d600fc6ea42626913ff021b516bea8bfe5a983d0cd89cee679e8d06ac8140f0f251e89ac6b35df7610d79f5b47
-EBUILD ipe-tools-7.2.20.1.ebuild 1433 BLAKE2B e2382d7717066fc85af8eb444dbadf894bcb0951b6e2cdf7e74632c88c3f6497e9e1f49a285a1798e6723f2d0b2341f4c2aeb52fb481466e96b38a1269ca4b9d SHA512 585f0bad892044ed50908c26459f8b925348896353eeca08db05e2e3180960f21422ba77af1e81e5c5340e6dcdc4f251dce65f21a6bbf30a2405457501eab9a1
-EBUILD ipe-tools-7.2.24.1.ebuild 1411 BLAKE2B 41860b4decd0cc98554a822b11db62d0d62230356b2597f61e502e82c946e2558d68008dd38c01cf8508b2f96eb01ef9990ca6a694bf0d66d3e41837c2a8741f SHA512 c7170e194990236d5aa5c1d65e99ad9538753e421a6cd80d6d019943ce661480bc31adcdb359c59b15e653ab8ba33d194acc27a7fdc8206b1dd131ba23f27d93
+EBUILD ipe-tools-7.2.24.1.ebuild 1411 BLAKE2B 6ae227856f0dfcff65ea1577712f247fa0735f269fc13f55d2cff07a7e389026d1e52cf984d4fa374a00ec10e18ffd4e1a07eeda2677169932f9b8d2fb187b18 SHA512 c0f4771d57bb6d6dd69e33e862876c23314d582552a26c6c269604e7bfd1e0593d98f9a044e6d653a94fabb12be1a6902d523b933515b1445dd6879e37a1154a
 MISC metadata.xml 243 BLAKE2B 889d08efb220a9fb8457500f5f3c33c8c737616995e19fa8b621ced4bc9d380d016413d098d4d09925c679cd23f7fbd75e495424fe6ed809a9e873014caae682 SHA512 f9051a65d7e11d7abd1b9568dbbf8be84a6ae68eb994b0c22d57dff5620047d5ad5a324057a5cf4cec10837d16024e5f21a8cf5f1a6247807f62931839eb73bc
diff --git a/media-gfx/ipe-tools/ipe-tools-7.2.20.1.ebuild b/media-gfx/ipe-tools/ipe-tools-7.2.20.1.ebuild
deleted file mode 100644 (file)
index 8f2fe1c..0000000
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{8..10} )
-inherit python-single-r1
-
-DESCRIPTION="Tools to use with the Ipe drawing editor."
-HOMEPAGE="https://github.com/otfried/ipe-tools"
-SRC_URI="https://github.com/otfried/ipe-tools/archive/v${PV}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="+annotate +svgtoipe +figtoipe +ipe5toxml +pdftoipe"
-
-DEPEND="annotate? ( ${PYTHON_DEPS} dev-python/PyPDF2 )
-               svgtoipe? ( !media-gfx/svgtoipe ${PYTHON_DEPS} dev-lang/python[xml] )
-               figtoipe? ( !media-gfx/figtoipe sys-libs/zlib )
-               ipe5toxml? ( !media-gfx/ipe5toxml )
-               pdftoipe? ( !media-gfx/pdftoipe app-text/poppler )"
-RDEPEND="${DEPEND}"
-BDEPEND=""
-
-src_compile() {
-       # Tools with makefile
-       for tool in figtoipe ipe5toxml; do
-               if use ${tool}; then
-                       cd ${tool}
-                       emake
-                       cd ..
-               fi
-       done
-
-       # Fixing python tool naming
-       use svgtoipe && mv svgtoipe/svgtoipe.py svgtoipe/svgtoipe
-       # File collision with annotate from media-libs/gd, hence suffix -ipe
-       use annotate && mv annotate/annotate.py annotate/annotate-ipe
-}
-
-src_install() {
-       exeinto /usr/bin/
-
-       for tool in svgtoipe figtoipe ipe5toxml; do
-               use ${tool} && doexe ${tool}/${tool}
-               use ${tool} && doman ${tool}/${tool}.1
-       done
-
-       use annotate && doexe annotate/annotate-ipe
-
-       # Fixing python tools
-       if use annotate || use svgtoipe; then
-               python_fix_shebang ${ED}/usr/bin
-       fi
-}
index bbd91e11e45746a8d3c64d9fcc2bc74124216049..8174474978d5332ff73480e3676c92a537d89137 100644 (file)
@@ -3,7 +3,7 @@
 
 EAPI=7
 
-PYTHON_COMPAT=( python3_{8..12} )
+PYTHON_COMPAT=( python3_{8..13} )
 inherit python-single-r1
 
 DESCRIPTION="Tools to use with the Ipe drawing editor."